Slow logon on first boot with Citrix Xenapp 7.5


Slow logon on first boot with Citrix XenApp 7.5

This quick and short blog will show you how to fix the slow logon at first boot that you might experience in a Citrix XenApp 7.5 environment.

Issue

The issue we encountered (@hdelannoy did) was that on a Citrix XenApp 7.5 server every first user had a logon delay of 180 seconds.
The other users that would logon later didn’t have this issue and could logon fast like expected. 

Troubleshooting

Troubleshooting started from the Citrix Director and showed that the interactive session was having a bad time, it was having a delay of 3 minutes it said. It always took 180 seconds but that might be environment specific.
Looking at the Event viewer we noticed the following event

The Citrix Profile management Group Policy Extension could not get the local profile location for user


6005
The winlogon notification subscriber is taking long time to handle the notification event (Logon).
6006
The winlogon notification subscriber took 63 second(s) to handle the notification event (Logon).

Solution

What we figured out (still giving credits to @hdelannoy) is that it you have to rename C:Program FilesCitrixUser Profile ManagerUPMPolicyDefaults_all.ini to something else. 
After that install the Microsoft hotfixes in this order exactly.

After we renamed the file and installed the hotfixes in the that order the issue was resolved.

Haven’t tested or experienced this with XenDesktop 7.5 but the hotfixes are identical it seems.
If you have more information about your issues and how you solved it, please let me know and I’ll add it to this post.

Leave a Reply

https://tracking.cirrusinsight.com/869c29e2-3a9b-48c5-9232-0b95e7993ae8/controlup-com-pixel-php